*SOLVED* AllTheMods v5.7c Launch Error (Tinkers' Construct required Forge ver.)

Wargarbl

New Member
Ascendant
Minecraft Username
Wargarbl
Issue Type: Defect

Steps to reproduce the problem:
1)
load lolnet launcher
2) install AllTheMods modpack
3) launch AllTheMods modpack
4) wait for freeze mid-load with error message

Expected output: loaded modpack ready to play
Actual output: launch halted, mid-load error message stating mod dependancy

OS: Windows 7 64-bit
Java: version 8 update 111 (build 1.8.0_111-b14)
Modpack: AllTheMods v5.7c
Launcher: Lolnet Launcher v1.1.20
Error Log: https://pastebin.com/e5FrubYH

--------DETAILS--------

It's possible the staff are already aware of this problem but as I can't see that anyone else has reported it (and the ATM pack has relatively few players currently that I'm aware of) I'm posting this just to be sure someone knows about it.

As of yesterday evening (30/1/2018) the AllTheMods pack seems to have had an update, but now the mod pack will not launch due to Tinkers' Construct requiring a version of Forge other than the one being loaded.

I have tried supplying the pack with an updated version of Forge but don't know where the config file is telling the pack which one to load, so I can't redirect it to load the correct file.

I am not the only one having this problem, it was initially brought to my attention by Mordring after I had played earlier that day.

The error which is displayed when the pack halts loading up is as follows

Tinkers' Construct is missing mods it depends on.
Include the following mods or remove Tinkers' Construct.

forge 14.23.1.2577 or above

See 'fml-client-latest.log' for technical information.

I have downloaded the latest launcher and tried a forced update on the pack several times since this problem arose, but have seen no change.

Screenshots of this error and the launcher are attached, log file mentioned in the error message is linked in pastebin above.

screenshot.2018-01-31.jpg screenshot.2018-01-31 (1).jpg
 

Wargarbl

New Member
Ascendant
Minecraft Username
Wargarbl
Forge should be updated to the correct version now
Thanks for the quick reply.

The pack loads up to the main menu fine now but I get errors when trying to join.

When attempting a direct-connect I get stonewalled with internal exception java.lang.nullpointerexception

And when attempting to join via lobby I receive modrejection errors shown in the screenshot attached.

screenshot.2018-01-31 (3).jpg
 

LX_Gaming

Administrator
Staff member
Developer
Minecraft Username
LX_Gaming
Buy me a coffee!
Whoops, Those mods were removed in the 5.7 update but I didn't remove them off the server.

Thank you for reporting this.
 

anarki99nz

Snr Moderator
Staff member
Paladin
Donation Drive 2017
Donation Drive 2018
Minecraft Username
anarki99nz
Can I just say, this was a great error report Wargarbl. All the info needed to resolve.
 

Wargarbl

New Member
Ascendant
Minecraft Username
Wargarbl
Whoops, Those mods were removed in the 5.7 update but I didn't remove them off the server.

Thank you for reporting this.
Cheers, I am able to connect to the server now.

Again, thanks for jumping on this so quickly.

@anarki99nz Thank you. It took 10+ minutes to slap it the initial report together, but I'd rather take the time to deliver all the recommended information than waste 24-hours of waiting just to see something like "but what version of java are you running?" tomorrow, when the problem could have been fixed already just by being thorough on my end.
 
Top