Can't launch game

aj2666

New Member
Minecraft Username
aj2666
Type: Can't launch game

What steps will reproduce the problem? (use screenshots if easier)
1)
2)
3)

What is the expected output? What do you see instead?

What is your OS? (windows 7 64 bit, linux ubuntu 14.10 32 bit, mac os x 10.7 64 bit, etc)
Mac
What version of java are you running?
8
What modPack are you running / trying to run?
Ultimate Reload
What version of LolnetLauncher are you using? (see top window, e.g. Lolnet Launcher (v0.9.12-SNAPSHOT)
V1.1.20
Do you have an error log of what happened? (please use pastebin and make sure it doesn't expire for 1 month or never)

Please provide any additional information below.

I keep getting the message "To use the java command-line tool you need to install a JDK
 

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
How did you install you Java? And what version of Java 8 are you running? Open a terminal (CMD+space and enter 'terminal') and run 'java -version' and (I think?) 'echo $JAVA_HOME' and post the output here.
 

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
And the other questions I asked?
 

aj2666

New Member
Minecraft Username
aj2666
JAVA was preinstalled on my computer when I got it. I just do updates when it notifies me to do so
 

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
The other two questions I asked will help me determine if your Java installation is properly setup. The launcher is likely trying to use the $JAVA_HOME variable to locate your Java; if it's not there, then it'll think there's nothing installed. So can you please run the other two commands I asked for and paste the output in here?

Alternatively, you can try to download and install the JRE from here, which should set up your system correctly: https://www.java.com/en/download/manual.jsp#mac It's the latest version, which is the version you say you have installed anyway, so it should just update the system variables, not change your Java at all.
 

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
Also, you can join our Discord and PM me there, or even just post in #general for help, might go a bit quicker if you're still having trouble after my last suggestions. :)

https://tiny.lolnet.co.nz/discord
 

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
That's showing you've somehow got Java 11 installed, and Minecraft only works with Java 8. The error message in the second screenshot is saying that a parameter passed to Java doesn't exist anymore; that parameter was removed in Java 9 or 10, I believe.

Did you grab the install from the link I gave above? It should have taken you to Java 8 update 201 for Mac?
 

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
What was the filename you downloaded? It should have been jre-8u201-macosx-x64.dmg?

macOS talk about Java 8, but I'm going to guess you have more than one Java installed. And the fact that when you run 'java -version', it picks Java 11 by default, which while the launcher might work fine with, Minecraft won't.
 

aj2666

New Member
Minecraft Username
aj2666
yes that was the filename

For some reason it seems like it won't change from 11. I've tried numerous ways to change it to 8 but it always seems to default back to 11. Think I might need apple support to sort it out
 

aj2666

New Member
Minecraft Username
aj2666
so after a lot of research apple support being useless because its a third party program I found what the issue is. When doing the command "java -version" that is actually showing you the java jdk version. basically I had to use this command to delete java jdk, then update to java jdk 8
 

Attachments

Cluracan

Moderator
Staff member
Developer
Ascendant
Donation Drive 2018
Minecraft Username
Cluracan
Awesome, does that mean you're working now?
 
Top